WSS 3.0 x64 to Sharepoint 2010 Foundation

Apr 28, 2010 at 10:18 PM

Does this tool support moving from WSS 3.0 to 2010 Foundation?  I uncommented the lines from the config file to enable 2010 support, but I get the following error when I try to import a library to 2010 that I exported from WSS 3.0:

[4/28/2010 2:15:01 PM] Start Time: 4/28/2010 2:15:01 PM.
[4/28/2010 2:15:01 PM] Progress: Initializing Import.
[4/28/2010 2:15:15 PM] FatalError: The version of the package 12.0.10.0 is different from the current version this program supports, 14.0.0.0.
[4/28/2010 2:15:15 PM] Debug:    at Microsoft.SharePoint.Deployment.SPDeploymentSchemaVersion.Validate(SPSite site)
   at Microsoft.SharePoint.Deployment.SPImport.Run()
[4/28/2010 2:15:15 PM] Progress: Import did not complete.
[4/28/2010 2:15:15 PM] Finish Time: 4/28/2010 2:15:15 PM.
[4/28/2010 2:15:15 PM] Duration: 00:00:13
[4/28/2010 2:15:15 PM] Finished with 0 warnings.
[4/28/2010 2:15:15 PM] Finished with 1 errors.

Nov 29, 2010 at 4:31 AM

Hi - Although the tool doesn't support this - I managed to hack the output so it worked for me.

Process is this:

- export in moss

- rename to .cab

-  extract cab

- fix up the xml file as described here: http://moss-arvit.blogspot.com/

- re-cab with the "Cab-Arc" tool from "CL Tools": http://www.softpedia.com/get/Others/Miscellaneous/CL-Tools-4Win.shtml

- rename back to cmp or whatever it was

- import into 2010

- sit back and have a beer and think how awesome that was.

 

tfforums