Error - Just-In-Time Debugging

May 4, 2010 at 8:45 PM

Hello Chris, I was trying to install the 2.8 version of the tool and after installing it on my SharePoint 2003 server, I tried to open the wizard and I got this JIT error.  I don't know why but the wizard is not coming up.  The error is what pops up.

An exception 'System.IO.FileNotFoundException' has occured in SPContentDeploymentWizard.exe.

However, no debuggers are registered that can debug this exception.  Unable to JIT debug.

 

Any help with this would be appreciated.  I am new to the Sharepoint environment, and was asked to migrate documents from Sharepoint 2003 to Sharepoint 2010.  Any advise??

Coordinator
May 5, 2010 at 9:30 AM

@srleviton,

Ah, the Content Deployment Wizard is a tool for SharePoint 2007 onwards - it will not run on SharePoint 2003.

Also, it cannot be used to migrate from one version of SharePoint to another (e.g. 2003 - 2010). It is purely for moving content around (perhaps between different environments) within the same version.

HTH,

Chris.

May 5, 2010 at 5:33 PM

thanks for you reply.  but is there any method of migrating document libraries from 2001 or 2003 to 2010?  I think a lot of people have the same question.  What would be the best practice to move sites and document libraries from an older version of Sharepoint like 2001 to 2010.  Any suggestion would be helpful.  Thanks again.

Coordinator
May 6, 2010 at 9:32 AM

@srleviton,

The typical route is to upgrade the environment using one of the standard upgrade approaches (e.g. in-place, content database attach etc.) rather than "migrate" content between the environments. If for some reason you need to use the "migrate" approach you'll most likely need a "pay for" tool.

There's lots of information on the normal upgrade approach on Technet, start here: http://technet.microsoft.com/en-us/sharepoint/ee517214.aspx

HTH,

Chris.